UPDATE: devel/boehm-gc 8.2.4>

This commit is contained in:
purplerain 2024-08-01 22:59:52 +00:00
parent fdd1de1e30
commit ed5349002a
Signed by: purplerain
GPG Key ID: F42C07F07E2E35B7
16 changed files with 721 additions and 0 deletions

76
devel/boehm-gc/Makefile Normal file
View File

@ -0,0 +1,76 @@
COMMENT-main= garbage collection and memory leak detection for C and C++
COMMENT-atomic= access to hardware provided atomic memory operations
VERSION= 8.2.4
LIBAO_VERSION= 7.8.0
# has various machine-dependent parts; updates definitely need
# tests on more than just amd64.
DISTNAME= gc-${VERSION}
PKGNAME-atomic= libatomic_ops-${LIBAO_VERSION}
PKGNAME-main= boehm-gc-${VERSION}
DISTFILES.lib = libatomic_ops-${LIBAO_VERSION}${EXTRACT_SUFX}
MULTI_PACKAGES= -main -atomic
DEBUG_PACKAGES= ${BUILD_PACKAGES}
SHARED_LIBS += gc 6.0 # 6.2
SHARED_LIBS += gccpp 1.0 # 5.0
SHARED_LIBS += gctba 0.0 # 5.0
SHARED_LIBS += cord 3.0 # 6.0
SHARED_LIBS += atomic_ops 3.0 # 3.0
SHARED_LIBS += atomic_ops_gpl 3.0 # 3.0
CATEGORIES= devel
SITES= https://github.com/ivmai/bdwgc/releases/download/v${VERSION}/
SITES.lib= https://github.com/ivmai/libatomic_ops/releases/download/v${LIBAO_VERSION}/
HOMEPAGE= https://hboehm.info/gc/
# currently works only on most ELF archs
NOT_FOR_ARCHS= m88k
# HP MIT-like license
PERMIT_PACKAGE= Yes
WANTLIB-main += m pthread ${COMPILER_LIBCXX}
COMPILER = base-clang ports-gcc base-gcc
MAKE_ENV= CP="cp" \
INSTALL_DATA="${INSTALL_DATA}" \
INSTALL_MAN="${INSTALL_MAN}"
CONFIGURE_STYLE= gnu
CONFIGURE_ARGS= --with-libatomic-ops=no \
--enable-cplusplus \
--enable-threads=pthreads \
--enable-mmap \
--enable-static=yes
.if ${MACHINE_ARCH} == "arm"
# Needs unwind symbols. We use MAKE_FLAGS because configure.ac doesn't respect
# UNWINDLIBS passed in CONFIGURE_ENV.
MAKE_FLAGS += UNWINDLIBS="-lc++abi"
.endif
post-extract:
@perl -pi -e "s,/usr/local,${PREFIX},g" ${WRKSRC}/doc/gc.man
@mv ${WRKDIR}/libatomic_ops-${LIBAO_VERSION} ${WRKBUILD}/libatomic_ops
pre-build:
# clean distributed objects and libs and rebuild
@cd ${WRKBUILD}/libatomic_ops && ${SETENV} ${MAKE_ENV} \
${MAKE_PROGRAM} ${MAKE_FLAGS} clean all
post-install:
@cd ${WRKBUILD}/libatomic_ops && ${SETENV} ${MAKE_ENV} \
${MAKE_PROGRAM} ${ALL_FAKE_FLAGS} install
${INSTALL_DATA} ${WRKSRC}/doc/gc.man ${PREFIX}/man/man3/gc.3
.include <bsd.port.mk>

4
devel/boehm-gc/distinfo Normal file
View File

@ -0,0 +1,4 @@
SHA256 (gc-8.2.4.tar.gz) = PQ082+B3QD0xBrtA8Mu1Y0E9bv27Kn4c1ohlld7Ej8I=
SHA256 (libatomic_ops-7.8.0.tar.gz) = FWdudnThG9paflCnP02efWBFInG4rPb9Oacf79+J+jE=
SIZE (gc-8.2.4.tar.gz) = 1210929
SIZE (libatomic_ops-7.8.0.tar.gz) = 526300

View File

@ -0,0 +1,12 @@
Index: Makefile.in
--- Makefile.in.orig
+++ Makefile.in
@@ -1448,7 +1448,7 @@ libatomic_ops/src/atomic_ops_sysdeps.lo: \
libatomic_ops/src/$(am__dirstamp) \
libatomic_ops/src/$(DEPDIR)/$(am__dirstamp)
-libgc.la: $(libgc_la_OBJECTS) $(libgc_la_DEPENDENCIES) $(EXTRA_libgc_la_DEPENDENCIES)
+libgc.la ./libgc.la: $(libgc_la_OBJECTS) $(libgc_la_DEPENDENCIES) $(EXTRA_libgc_la_DEPENDENCIES)
$(AM_V_CCLD)$(libgc_la_LINK) -rpath $(libdir) $(libgc_la_OBJECTS) $(libgc_la_LIBADD) $(LIBS)
libgccpp.la: $(libgccpp_la_OBJECTS) $(libgccpp_la_DEPENDENCIES) $(EXTRA_libgccpp_la_DEPENDENCIES)

View File

@ -0,0 +1,112 @@
Index: configure
--- configure.orig
+++ configure
@@ -6565,7 +6565,7 @@ else $as_nop
lt_cv_sys_max_cmd_len=8192;
;;
- bitrig* | darwin* | dragonfly* | freebsd* | midnightbsd* | netbsd* | openbsd*)
+ bitrig* | darwin* | dragonfly* | freebsd* | midnightbsd* | netbsd* | openbsd* | secbsd*)
# This has been around since 386BSD, at least. Likely further.
if test -x /sbin/sysctl; then
lt_cv_sys_max_cmd_len=`/sbin/sysctl -n kern.argmax`
@@ -7104,7 +7104,7 @@ freebsd* | dragonfly* | midnightbsd*)
i*86 )
# Not sure whether the presence of OpenBSD here was a mistake.
# Let's accept both of them until this is cleared up.
- lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD|DragonFly)/i[3-9]86 (compact )?demand paged shared library'
+ lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD|SecBSD|DragonFly)/i[3-9]86 (compact )?demand paged shared library'
lt_cv_file_magic_cmd=$FILECMD
lt_cv_file_magic_test_file=`echo /usr/lib/libc.so.*`
;;
@@ -7174,7 +7174,7 @@ newos6*)
lt_cv_deplibs_check_method=pass_all
;;
-openbsd* | bitrig*)
+openbsd* | bitrig* | secbsd*)
if test -z "`echo __ELF__ | $CC -E - | $GREP __ELF__`"; then
lt_cv_deplibs_check_method='match_pattern /lib[^/]+(\.so\.[0-9]+\.[0-9]+|\.so|_pic\.a)$'
else
@@ -7853,7 +7853,7 @@ old_postuninstall_cmds=
if test -n "$RANLIB"; then
case $host_os in
- bitrig* | openbsd*)
+ bitrig* | openbsd* | secbsd*)
old_postinstall_cmds="$old_postinstall_cmds~\$RANLIB -t \$tool_oldlib"
;;
*)
@@ -10757,7 +10757,7 @@ printf %s "checking whether the $compiler linker ($LD)
# we just hope/assume this is gcc and not c89 (= MSVC++ or ICC)
with_gnu_ld=yes
;;
- openbsd* | bitrig*)
+ openbsd* | bitrig* | secbsd*)
with_gnu_ld=no
;;
esac
@@ -11735,7 +11735,7 @@ printf "%s\n" "$lt_cv_irix_exported_symbol" >&6; }
*nto* | *qnx*)
;;
- openbsd* | bitrig*)
+ openbsd* | bitrig* | secbsd*)
if test -f /usr/libexec/ld.so; then
hardcode_direct=yes
hardcode_shlibpath_var=no
@@ -12870,7 +12870,7 @@ newsos6)
dynamic_linker='ldqnx.so'
;;
-openbsd* | bitrig*)
+openbsd* | bitrig* | secbsd*)
version_type=sunos
sys_lib_dlsearch_path_spec=/usr/lib
need_lib_prefix=no
@@ -15046,7 +15046,7 @@ fi
ld_shlibs_CXX=yes
;;
- openbsd* | bitrig*)
+ openbsd* | bitrig* | secbsd*)
if test -f /usr/libexec/ld.so; then
hardcode_direct_CXX=yes
hardcode_shlibpath_var_CXX=no
@@ -16859,7 +16859,7 @@ newsos6)
dynamic_linker='ldqnx.so'
;;
-openbsd* | bitrig*)
+openbsd* | bitrig* | secbsd*)
version_type=sunos
sys_lib_dlsearch_path_spec=/usr/lib
need_lib_prefix=no
@@ -17419,7 +17419,7 @@ case "$THREADS" in
*-*-aix* | *-*-android* | *-*-cygwin* | *-*-darwin* | *-*-dragonfly* | \
*-*-freebsd* | *-*-haiku* | *-*-hpux11* | *-*-irix* | \
*-*-kfreebsd*-gnu | *-*-gnu* | *-*-*linux* | *-*-msys* | *-*-nacl* | \
- *-*-netbsd* | *-*-openbsd* | *-*-osf* | *-*-solaris*)
+ *-*-netbsd* | *-*-openbsd* | *-*-osf* | *-*-secbsd* | *-*-solaris*)
printf "%s\n" "#define GC_THREADS 1" >>confdefs.h
@@ -17482,7 +17482,7 @@ printf "%s\n" "$as_me: WARNING: \"Only HP/UX 11 POSIX
# HPUX needs REENTRANT for the _r calls.
need_lib_rt=true
;;
- *-*-openbsd*)
+ *-*-openbsd* | *-*-secbsd*)
AM_CFLAGS="$AM_CFLAGS -pthread"
THREADDLLIBS=-pthread
;;
@@ -19247,7 +19247,8 @@ elif test "${enable_handle_fork}" != manual -a x$THREA
;;
*-*-aix* | *-*-android* | *-*-cygwin* | *-*-freebsd* | *-*-haiku* | \
*-*-hpux11* | *-*-irix* | *-*-kfreebsd*-gnu | \
- *-*-*linux* | *-*-netbsd* | *-*-openbsd* | *-*-osf* | *-*-solaris*)
+ *-*-*linux* | *-*-netbsd* | *-*-openbsd* | *-*-osf* | *-*-secbsd* | \
+ *-*-solaris*)
printf "%s\n" "#define HANDLE_FORK 1" >>confdefs.h
;;

View File

@ -0,0 +1,19 @@
- Remove old HAVE_DL_ITERATE_PHDR workaround for OpenBSD
Index: dyn_load.c
--- dyn_load.c.orig
+++ dyn_load.c
@@ -82,13 +82,6 @@ STATIC GC_has_static_roots_func GC_has_static_roots =
# define ELFSIZE ARCH_ELFSIZE
#endif
-#if defined(OPENBSD)
-# include <sys/param.h>
-# if (OpenBSD >= 200519) && !defined(HAVE_DL_ITERATE_PHDR)
-# define HAVE_DL_ITERATE_PHDR
-# endif
-#endif /* OPENBSD */
-
#if defined(SCO_ELF) || defined(DGUX) || defined(HURD) || defined(NACL) \
|| (defined(__ELF__) && (defined(LINUX) || defined(FREEBSD) \
|| defined(NETBSD) || defined(OPENBSD)))

View File

@ -0,0 +1,12 @@
Index: include/private/gcconfig.h
--- include/private/gcconfig.h.orig
+++ include/private/gcconfig.h
@@ -116,7 +116,7 @@ EXTERN_C_BEGIN
# endif
/* And one for OpenBSD: */
-# if defined(__OpenBSD__)
+# if defined(__OpenBSD__) || defined(__SecBSD__)
# define OPENBSD
# endif

View File

@ -0,0 +1,75 @@
Index: libatomic_ops/configure
--- libatomic_ops/configure.orig
+++ libatomic_ops/configure
@@ -5557,7 +5557,7 @@ else $as_nop
lt_cv_sys_max_cmd_len=8192;
;;
- bitrig* | darwin* | dragonfly* | freebsd* | midnightbsd* | netbsd* | openbsd*)
+ bitrig* | darwin* | dragonfly* | freebsd* | midnightbsd* | netbsd* | openbsd* | secbsd*)
# This has been around since 386BSD, at least. Likely further.
if test -x /sbin/sysctl; then
lt_cv_sys_max_cmd_len=`/sbin/sysctl -n kern.argmax`
@@ -6096,7 +6096,7 @@ freebsd* | dragonfly* | midnightbsd*)
i*86 )
# Not sure whether the presence of OpenBSD here was a mistake.
# Let's accept both of them until this is cleared up.
- lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD|DragonFly)/i[3-9]86 (compact )?demand paged shared library'
+ lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD|SecBSD|DragonFly)/i[3-9]86 (compact )?demand paged shared library'
lt_cv_file_magic_cmd=$FILECMD
lt_cv_file_magic_test_file=`echo /usr/lib/libc.so.*`
;;
@@ -6166,7 +6166,7 @@ newos6*)
lt_cv_deplibs_check_method=pass_all
;;
-openbsd* | bitrig*)
+openbsd* | bitrig* | secbsd*)
if test -z "`echo __ELF__ | $CC -E - | $GREP __ELF__`"; then
lt_cv_deplibs_check_method='match_pattern /lib[^/]+(\.so\.[0-9]+\.[0-9]+|\.so|_pic\.a)$'
else
@@ -6845,7 +6845,7 @@ old_postuninstall_cmds=
if test -n "$RANLIB"; then
case $host_os in
- bitrig* | openbsd*)
+ bitrig* | openbsd* | secbsd*)
old_postinstall_cmds="$old_postinstall_cmds~\$RANLIB -t \$tool_oldlib"
;;
*)
@@ -9738,7 +9738,7 @@ printf %s "checking whether the $compiler linker ($LD)
# we just hope/assume this is gcc and not c89 (= MSVC++ or ICC)
with_gnu_ld=yes
;;
- openbsd* | bitrig*)
+ openbsd* | bitrig* | secbsd*)
with_gnu_ld=no
;;
esac
@@ -10716,7 +10716,7 @@ printf "%s\n" "$lt_cv_irix_exported_symbol" >&6; }
*nto* | *qnx*)
;;
- openbsd* | bitrig*)
+ openbsd* | bitrig* | secbsd*)
if test -f /usr/libexec/ld.so; then
hardcode_direct=yes
hardcode_shlibpath_var=no
@@ -11851,7 +11851,7 @@ newsos6)
dynamic_linker='ldqnx.so'
;;
-openbsd* | bitrig*)
+openbsd* | bitrig* | secbsd*)
version_type=sunos
sys_lib_dlsearch_path_spec=/usr/lib
need_lib_prefix=no
@@ -13313,7 +13313,7 @@ if test x$have_pthreads = xtrue; then
printf "%s\n" "#define _PTHREADS 1" >>confdefs.h
;;
- *-*-openbsd* | *-*-kfreebsd*-gnu | *-*-dgux*)
+ *-*-openbsd* | *-*-secbsd* | *-*-kfreebsd*-gnu | *-*-dgux*)
THREADDLLIBS=-pthread
;;
*-*-cygwin* | *-*-darwin*)

View File

@ -0,0 +1,30 @@
Index: libatomic_ops/ltmain.sh
--- libatomic_ops/ltmain.sh.orig
+++ libatomic_ops/ltmain.sh
@@ -7283,7 +7283,7 @@ func_mode_link ()
# These systems don't actually have a C library (as such)
test X-lc = "X$arg" && continue
;;
- *-*-openbsd* | *-*-freebsd* | *-*-dragonfly* | *-*-bitrig* | *-*-midnightbsd*)
+ *-*-openbsd* | *-*-secbsd* | *-*-freebsd* | *-*-dragonfly* | *-*-bitrig* | *-*-midnightbsd*)
# Do not include libc due to us having libc/libc_r.
test X-lc = "X$arg" && continue
;;
@@ -7303,7 +7303,7 @@ func_mode_link ()
esac
elif test X-lc_r = "X$arg"; then
case $host in
- *-*-openbsd* | *-*-freebsd* | *-*-dragonfly* | *-*-bitrig* | *-*-midnightbsd*)
+ *-*-openbsd* | *-*-secbsd* | *-*-freebsd* | *-*-dragonfly* | *-*-bitrig* | *-*-midnightbsd*)
# Do not include libc_r directly, use -pthread flag.
continue
;;
@@ -9408,7 +9408,7 @@ func_mode_link ()
*-*-netbsd*)
# Don't link with libc until the a.out ld.so is fixed.
;;
- *-*-openbsd* | *-*-freebsd* | *-*-dragonfly* | *-*-midnightbsd*)
+ *-*-openbsd* | *-*-secbsd* | *-*-freebsd* | *-*-dragonfly* | *-*-midnightbsd*)
# Do not include libc due to us having libc/libc_r.
;;
*-*-sco3.2v5* | *-*-sco5v6*)

View File

@ -0,0 +1,75 @@
Index: libatomic_ops/m4/libtool.m4
--- libatomic_ops/m4/libtool.m4.orig
+++ libatomic_ops/m4/libtool.m4
@@ -1557,7 +1557,7 @@ old_postuninstall_cmds=
if test -n "$RANLIB"; then
case $host_os in
- bitrig* | openbsd*)
+ bitrig* | openbsd* | secbsd*)
old_postinstall_cmds="$old_postinstall_cmds~\$RANLIB -t \$tool_oldlib"
;;
*)
@@ -1725,7 +1725,7 @@ AC_CACHE_VAL([lt_cv_sys_max_cmd_len], [dnl
lt_cv_sys_max_cmd_len=8192;
;;
- bitrig* | darwin* | dragonfly* | freebsd* | midnightbsd* | netbsd* | openbsd*)
+ bitrig* | darwin* | dragonfly* | freebsd* | midnightbsd* | netbsd* | openbsd* | secbsd*)
# This has been around since 386BSD, at least. Likely further.
if test -x /sbin/sysctl; then
lt_cv_sys_max_cmd_len=`/sbin/sysctl -n kern.argmax`
@@ -2944,7 +2944,7 @@ newsos6)
dynamic_linker='ldqnx.so'
;;
-openbsd* | bitrig*)
+openbsd* | bitrig* | secbsd*)
version_type=sunos
sys_lib_dlsearch_path_spec=/usr/lib
need_lib_prefix=no
@@ -3514,7 +3514,7 @@ freebsd* | dragonfly* | midnightbsd*)
i*86 )
# Not sure whether the presence of OpenBSD here was a mistake.
# Let's accept both of them until this is cleared up.
- lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD|DragonFly)/i[[3-9]]86 (compact )?demand paged shared library'
+ lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD|SecBSD|DragonFly)/i[[3-9]]86 (compact )?demand paged shared library'
lt_cv_file_magic_cmd=$FILECMD
lt_cv_file_magic_test_file=`echo /usr/lib/libc.so.*`
;;
@@ -3584,7 +3584,7 @@ newos6*)
lt_cv_deplibs_check_method=pass_all
;;
-openbsd* | bitrig*)
+openbsd* | bitrig* | secbsd*)
if test -z "`echo __ELF__ | $CC -E - | $GREP __ELF__`"; then
lt_cv_deplibs_check_method='match_pattern /lib[[^/]]+(\.so\.[[0-9]]+\.[[0-9]]+|\.so|_pic\.a)$'
else
@@ -5015,7 +5015,7 @@ dnl Note also adjust exclude_expsyms for C++ above.
# we just hope/assume this is gcc and not c89 (= MSVC++ or ICC)
with_gnu_ld=yes
;;
- openbsd* | bitrig*)
+ openbsd* | bitrig* | secbsd*)
with_gnu_ld=no
;;
esac
@@ -5837,7 +5837,7 @@ _LT_EOF
*nto* | *qnx*)
;;
- openbsd* | bitrig*)
+ openbsd* | bitrig* | secbsd*)
if test -f /usr/libexec/ld.so; then
_LT_TAGVAR(hardcode_direct, $1)=yes
_LT_TAGVAR(hardcode_shlibpath_var, $1)=no
@@ -7131,7 +7131,7 @@ if test yes != "$_lt_caught_CXX_error"; then
_LT_TAGVAR(ld_shlibs, $1)=yes
;;
- openbsd* | bitrig*)
+ openbsd* | bitrig* | secbsd*)
if test -f /usr/libexec/ld.so; then
_LT_TAGVAR(hardcode_direct, $1)=yes
_LT_TAGVAR(hardcode_shlibpath_var, $1)=no

View File

@ -0,0 +1,30 @@
Index: ltmain.sh
--- ltmain.sh.orig
+++ ltmain.sh
@@ -7283,7 +7283,7 @@ func_mode_link ()
# These systems don't actually have a C library (as such)
test X-lc = "X$arg" && continue
;;
- *-*-openbsd* | *-*-freebsd* | *-*-dragonfly* | *-*-bitrig* | *-*-midnightbsd*)
+ *-*-openbsd* | *-*-secbsd* | *-*-freebsd* | *-*-dragonfly* | *-*-bitrig* | *-*-midnightbsd*)
# Do not include libc due to us having libc/libc_r.
test X-lc = "X$arg" && continue
;;
@@ -7303,7 +7303,7 @@ func_mode_link ()
esac
elif test X-lc_r = "X$arg"; then
case $host in
- *-*-openbsd* | *-*-freebsd* | *-*-dragonfly* | *-*-bitrig* | *-*-midnightbsd*)
+ *-*-openbsd* | *-*-secbsd* | *-*-freebsd* | *-*-dragonfly* | *-*-bitrig* | *-*-midnightbsd*)
# Do not include libc_r directly, use -pthread flag.
continue
;;
@@ -9408,7 +9408,7 @@ func_mode_link ()
*-*-netbsd*)
# Don't link with libc until the a.out ld.so is fixed.
;;
- *-*-openbsd* | *-*-freebsd* | *-*-dragonfly* | *-*-midnightbsd*)
+ *-*-openbsd* | *-*-secbsd* | *-*-freebsd* | *-*-dragonfly* | *-*-midnightbsd*)
# Do not include libc due to us having libc/libc_r.
;;
*-*-sco3.2v5* | *-*-sco5v6*)

View File

@ -0,0 +1,75 @@
Index: m4/libtool.m4
--- m4/libtool.m4.orig
+++ m4/libtool.m4
@@ -1557,7 +1557,7 @@ old_postuninstall_cmds=
if test -n "$RANLIB"; then
case $host_os in
- bitrig* | openbsd*)
+ bitrig* | openbsd* | secbsd*)
old_postinstall_cmds="$old_postinstall_cmds~\$RANLIB -t \$tool_oldlib"
;;
*)
@@ -1725,7 +1725,7 @@ AC_CACHE_VAL([lt_cv_sys_max_cmd_len], [dnl
lt_cv_sys_max_cmd_len=8192;
;;
- bitrig* | darwin* | dragonfly* | freebsd* | midnightbsd* | netbsd* | openbsd*)
+ bitrig* | darwin* | dragonfly* | freebsd* | midnightbsd* | netbsd* | openbsd* | secbsd*)
# This has been around since 386BSD, at least. Likely further.
if test -x /sbin/sysctl; then
lt_cv_sys_max_cmd_len=`/sbin/sysctl -n kern.argmax`
@@ -2944,7 +2944,7 @@ newsos6)
dynamic_linker='ldqnx.so'
;;
-openbsd* | bitrig*)
+openbsd* | bitrig* | secbsd)
version_type=sunos
sys_lib_dlsearch_path_spec=/usr/lib
need_lib_prefix=no
@@ -3514,7 +3514,7 @@ freebsd* | dragonfly* | midnightbsd*)
i*86 )
# Not sure whether the presence of OpenBSD here was a mistake.
# Let's accept both of them until this is cleared up.
- lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD|DragonFly)/i[[3-9]]86 (compact )?demand paged shared library'
+ lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD|SecBSD|DragonFly)/i[[3-9]]86 (compact )?demand paged shared library'
lt_cv_file_magic_cmd=$FILECMD
lt_cv_file_magic_test_file=`echo /usr/lib/libc.so.*`
;;
@@ -3584,7 +3584,7 @@ newos6*)
lt_cv_deplibs_check_method=pass_all
;;
-openbsd* | bitrig*)
+openbsd* | bitrig* | secbsd*)
if test -z "`echo __ELF__ | $CC -E - | $GREP __ELF__`"; then
lt_cv_deplibs_check_method='match_pattern /lib[[^/]]+(\.so\.[[0-9]]+\.[[0-9]]+|\.so|_pic\.a)$'
else
@@ -5015,7 +5015,7 @@ dnl Note also adjust exclude_expsyms for C++ above.
# we just hope/assume this is gcc and not c89 (= MSVC++ or ICC)
with_gnu_ld=yes
;;
- openbsd* | bitrig*)
+ openbsd* | bitrig* | secbsd*)
with_gnu_ld=no
;;
esac
@@ -5837,7 +5837,7 @@ _LT_EOF
*nto* | *qnx*)
;;
- openbsd* | bitrig*)
+ openbsd* | bitrig* | secbsd*)
if test -f /usr/libexec/ld.so; then
_LT_TAGVAR(hardcode_direct, $1)=yes
_LT_TAGVAR(hardcode_shlibpath_var, $1)=no
@@ -7131,7 +7131,7 @@ if test yes != "$_lt_caught_CXX_error"; then
_LT_TAGVAR(ld_shlibs, $1)=yes
;;
- openbsd* | bitrig*)
+ openbsd* | bitrig* | secbsd*)
if test -f /usr/libexec/ld.so; then
_LT_TAGVAR(hardcode_direct, $1)=yes
_LT_TAGVAR(hardcode_shlibpath_var, $1)=no

View File

@ -0,0 +1,14 @@
- Fix unused variable old_segv_handler and old_bus_handler
Index: os_dep.c
--- os_dep.c.orig
+++ os_dep.c
@@ -887,7 +887,7 @@ GC_INNER size_t GC_page_size = 0;
# if defined(SUNOS5SIGS) || defined(IRIX5) || defined(OSF1) \
|| defined(HAIKU) || defined(HURD) || defined(FREEBSD) \
- || defined(NETBSD)
+ || defined(NETBSD) || defined(OPENBSD)
static struct sigaction old_segv_act;
# if defined(_sigargs) /* !Irix6.x */ || defined(HPUX) \
|| defined(HURD) || defined(NETBSD) || defined(FREEBSD)

View File

@ -0,0 +1,9 @@
This package provides semi-portable access to hardware provided
atomic memory operations. These might allow you to write code:
- That does more interesting things in signal handlers.
- Makes more effective use of multiprocessors by allowing you to write
clever lock-free code. Note that such code is very difficult to get
right, and will unavoidably be less portable than lock-based code. It
is also not always faster than lock-based code. But it may occasionally
be a large performance win.

View File

@ -0,0 +1,11 @@
The Boehm-Demers-Weiser garbage collection package, for C and C++ -
garbage collection and memory leak detection libraries.
A garbage collector is something which automatically frees malloc'd
memory for you by working out what parts of memory your program
no longer has pointers to. As a result, garbage collectors can also
inform you of memory leaks (if they find memory they can free, it means
you have lost all of your pointers to it, but you didn't free it).
C programs should run without change. C++ programs must include a header
to use garbage collection. See the man page and header files.

View File

@ -0,0 +1,95 @@
include/atomic_ops/
include/atomic_ops.h
include/atomic_ops/ao_version.h
include/atomic_ops/generalize-arithm.h
include/atomic_ops/generalize-small.h
include/atomic_ops/generalize.h
include/atomic_ops/sysdeps/
include/atomic_ops/sysdeps/all_acquire_release_volatile.h
include/atomic_ops/sysdeps/all_aligned_atomic_load_store.h
include/atomic_ops/sysdeps/all_atomic_load_store.h
include/atomic_ops/sysdeps/all_atomic_only_load.h
include/atomic_ops/sysdeps/ao_t_is_int.h
include/atomic_ops/sysdeps/armcc/
include/atomic_ops/sysdeps/armcc/arm_v6.h
include/atomic_ops/sysdeps/emul_cas.h
include/atomic_ops/sysdeps/gcc/
include/atomic_ops/sysdeps/gcc/aarch64.h
include/atomic_ops/sysdeps/gcc/alpha.h
include/atomic_ops/sysdeps/gcc/arm.h
include/atomic_ops/sysdeps/gcc/avr32.h
include/atomic_ops/sysdeps/gcc/cris.h
include/atomic_ops/sysdeps/gcc/e2k.h
include/atomic_ops/sysdeps/gcc/generic-arithm.h
include/atomic_ops/sysdeps/gcc/generic-small.h
include/atomic_ops/sysdeps/gcc/generic.h
include/atomic_ops/sysdeps/gcc/hexagon.h
include/atomic_ops/sysdeps/gcc/hppa.h
include/atomic_ops/sysdeps/gcc/ia64.h
include/atomic_ops/sysdeps/gcc/m68k.h
include/atomic_ops/sysdeps/gcc/mips.h
include/atomic_ops/sysdeps/gcc/powerpc.h
include/atomic_ops/sysdeps/gcc/riscv.h
include/atomic_ops/sysdeps/gcc/s390.h
include/atomic_ops/sysdeps/gcc/sh.h
include/atomic_ops/sysdeps/gcc/sparc.h
include/atomic_ops/sysdeps/gcc/tile.h
include/atomic_ops/sysdeps/gcc/x86.h
include/atomic_ops/sysdeps/generic_pthread.h
include/atomic_ops/sysdeps/hpc/
include/atomic_ops/sysdeps/hpc/hppa.h
include/atomic_ops/sysdeps/hpc/ia64.h
include/atomic_ops/sysdeps/ibmc/
include/atomic_ops/sysdeps/ibmc/powerpc.h
include/atomic_ops/sysdeps/icc/
include/atomic_ops/sysdeps/icc/ia64.h
include/atomic_ops/sysdeps/loadstore/
include/atomic_ops/sysdeps/loadstore/acquire_release_volatile.h
include/atomic_ops/sysdeps/loadstore/atomic_load.h
include/atomic_ops/sysdeps/loadstore/atomic_store.h
include/atomic_ops/sysdeps/loadstore/char_acquire_release_volatile.h
include/atomic_ops/sysdeps/loadstore/char_atomic_load.h
include/atomic_ops/sysdeps/loadstore/char_atomic_store.h
include/atomic_ops/sysdeps/loadstore/double_atomic_load_store.h
include/atomic_ops/sysdeps/loadstore/int_acquire_release_volatile.h
include/atomic_ops/sysdeps/loadstore/int_atomic_load.h
include/atomic_ops/sysdeps/loadstore/int_atomic_store.h
include/atomic_ops/sysdeps/loadstore/ordered_loads_only.h
include/atomic_ops/sysdeps/loadstore/ordered_stores_only.h
include/atomic_ops/sysdeps/loadstore/short_acquire_release_volatile.h
include/atomic_ops/sysdeps/loadstore/short_atomic_load.h
include/atomic_ops/sysdeps/loadstore/short_atomic_store.h
include/atomic_ops/sysdeps/msftc/
include/atomic_ops/sysdeps/msftc/arm.h
include/atomic_ops/sysdeps/msftc/arm64.h
include/atomic_ops/sysdeps/msftc/common32_defs.h
include/atomic_ops/sysdeps/msftc/x86.h
include/atomic_ops/sysdeps/msftc/x86_64.h
include/atomic_ops/sysdeps/ordered.h
include/atomic_ops/sysdeps/ordered_except_wr.h
include/atomic_ops/sysdeps/read_ordered.h
include/atomic_ops/sysdeps/standard_ao_double_t.h
include/atomic_ops/sysdeps/sunc/
include/atomic_ops/sysdeps/sunc/sparc.h
include/atomic_ops/sysdeps/sunc/x86.h
include/atomic_ops/sysdeps/test_and_set_t_is_ao_t.h
include/atomic_ops/sysdeps/test_and_set_t_is_char.h
include/atomic_ops_malloc.h
include/atomic_ops_stack.h
@static-lib lib/libatomic_ops.a
lib/libatomic_ops.la
@lib lib/libatomic_ops.so.${LIBatomic_ops_VERSION}
@static-lib lib/libatomic_ops_gpl.a
lib/libatomic_ops_gpl.la
@lib lib/libatomic_ops_gpl.so.${LIBatomic_ops_gpl_VERSION}
lib/pkgconfig/atomic_ops.pc
share/doc/libatomic_ops/
share/doc/libatomic_ops/AUTHORS
share/doc/libatomic_ops/COPYING
share/doc/libatomic_ops/ChangeLog
share/doc/libatomic_ops/LICENSE
share/doc/libatomic_ops/README.md
share/doc/libatomic_ops/README_details.txt
share/doc/libatomic_ops/README_malloc.txt
share/doc/libatomic_ops/README_stack.txt
share/doc/libatomic_ops/README_win32.txt

View File

@ -0,0 +1,72 @@
@pkgpath devel/boehm-gc
include/gc/
include/gc.h
include/gc/cord.h
include/gc/cord_pos.h
include/gc/ec.h
include/gc/gc.h
include/gc/gc_allocator.h
include/gc/gc_backptr.h
include/gc/gc_config_macros.h
include/gc/gc_cpp.h
include/gc/gc_disclaim.h
include/gc/gc_gcj.h
include/gc/gc_inline.h
include/gc/gc_mark.h
include/gc/gc_pthread_redirects.h
include/gc/gc_tiny_fl.h
include/gc/gc_typed.h
include/gc/gc_version.h
include/gc/javaxfc.h
include/gc/leak_detector.h
include/gc_cpp.h
@static-lib lib/libcord.a
lib/libcord.la
@lib lib/libcord.so.${LIBcord_VERSION}
@static-lib lib/libgc.a
lib/libgc.la
@lib lib/libgc.so.${LIBgc_VERSION}
@static-lib lib/libgccpp.a
lib/libgccpp.la
@lib lib/libgccpp.so.${LIBgccpp_VERSION}
@static-lib lib/libgctba.a
lib/libgctba.la
@lib lib/libgctba.so.${LIBgctba_VERSION}
lib/pkgconfig/bdw-gc.pc
@man man/man3/gc.3
@comment share/gc/gc.man
share/doc/gc/
share/doc/gc/AUTHORS
share/doc/gc/README.DGUX386
share/doc/gc/README.Mac
share/doc/gc/README.OS2
share/doc/gc/README.amiga
share/doc/gc/README.arm.cross
share/doc/gc/README.autoconf
share/doc/gc/README.cmake
share/doc/gc/README.cords
share/doc/gc/README.darwin
share/doc/gc/README.emscripten
share/doc/gc/README.environment
share/doc/gc/README.ews4800
share/doc/gc/README.hp
share/doc/gc/README.linux
share/doc/gc/README.macros
share/doc/gc/README.md
share/doc/gc/README.rs6000
share/doc/gc/README.sgi
share/doc/gc/README.solaris2
share/doc/gc/README.symbian
share/doc/gc/README.uts
share/doc/gc/README.win32
share/doc/gc/README.win64
share/doc/gc/debugging.md
share/doc/gc/finalization.md
share/doc/gc/gcdescr.md
share/doc/gc/gcinterface.md
share/doc/gc/leak.md
share/doc/gc/overview.md
share/doc/gc/porting.md
share/doc/gc/scale.md
share/doc/gc/simple_example.md
share/doc/gc/tree.md