Update coreboot-utils to version 4.21, patch from cat <cat@plan9.rocks>

This update adds the cbfstool binary.

kn@: port-wise this looks good
This commit is contained in:
sdk 2023-10-29 07:04:28 +00:00
parent 117182b728
commit 7401f13598
6 changed files with 28 additions and 7 deletions

View File

@ -4,10 +4,9 @@ ONLY_FOR_ARCHS = amd64
COMMENT = utilities to work on firmware images and hardware
V = 4.17
V = 4.21
DISTNAME = coreboot-${V}
PKGNAME = coreboot-utils-${V}
REVISION = 0
CATEGORIES = sysutils devel
@ -21,7 +20,7 @@ WANTLIB = c
SITES = https://coreboot.org/releases/
EXTRACT_SUFX = .tar.xz
EXTRACT_FILES = ${DISTNAME}/{src/commonlib,util}
EXTRACT_FILES = ${DISTNAME}/{src/commonlib,src/vendorcode,util,3rdparty}
USE_GMAKE = Yes
@ -34,7 +33,8 @@ MAKE_FLAGS = CC=${CC} \
FAKE_FLAGS = PREFIX=${PREFIX}
# XXX intelmetool requires unsupported pcilib access methods
UTILS = cbmem \
UTILS = cbfstool \
cbmem \
ectool \
ifdtool \
nvramtool

View File

@ -1,2 +1,2 @@
SHA256 (coreboot-4.17.tar.xz) = ldoR0cakUDhRAaaHmSWKOYzpZfTkbM5v6NXr105QwSU=
SIZE (coreboot-4.17.tar.xz) = 55676844
SHA256 (coreboot-4.21.tar.xz) = /RtIhHnBZNgU03Ocw7bPm/WH+INywWayToaGABWAlWU=
SIZE (coreboot-4.21.tar.xz) = 59528772

View File

@ -0,0 +1,11 @@
Index: util/cbfstool/Makefile.inc
--- util/cbfstool/Makefile.inc.orig
+++ util/cbfstool/Makefile.inc
@@ -134,7 +134,6 @@ TOOLCPPFLAGS += -I$(top)/src
TOOLCPPFLAGS += -I$(top)/src/vendorcode/intel/edk2/uefi_2.4/MdePkg/Include
TOOLLDFLAGS ?=
-HOSTCFLAGS += -fms-extensions
ifeq ($(shell uname -s | cut -c-7 2>/dev/null), MINGW32)
TOOLCFLAGS += -mno-ms-bitfields

View File

@ -3,7 +3,7 @@ Hint at mem(4) in error message
Index: util/cbmem/cbmem.c
--- util/cbmem/cbmem.c.orig
+++ util/cbmem/cbmem.c
@@ -1582,7 +1582,7 @@ int main(int argc, char** argv)
@@ -1811,7 +1811,7 @@ int main(int argc, char** argv)
mem_fd = open("/dev/mem", timestamp_id ? O_RDWR : O_RDONLY, 0);
if (mem_fd < 0) {

View File

@ -5,6 +5,7 @@ Source project it provides auditability and maximum control over technology.
This package contains the following utilities to work on firmware images or to
communicate with hardware:
* cbfstool Management utility for CBFS formatted ROM images
* cbmem CBMEM parser to read e.g. timestamps and console log
* ectool Dump the RAM of a laptop's Embedded/Environmental Controller (EC)
* ifdtool Extract and dump Intel Firmware Descriptor information

View File

@ -1,4 +1,13 @@
@comment @bin bin/cbfs-compression-tool
@bin bin/cbfstool
@comment @bin bin/cse_fpt
@comment @bin bin/cse_serger
@comment @bin bin/elogtool
@comment @bin bin/fmaptool
@bin bin/ifdtool
@comment @bin bin/ifittool
@comment @bin bin/ifwitool
@comment @bin bin/rmodtool
@man man/man8/nvramtool.8
@bin sbin/cbmem
@bin sbin/ectool