update to barman-3.9.0

This commit is contained in:
sthen 2023-10-11 13:28:14 +00:00
parent 7d86685fb8
commit 7685b7fc08
5 changed files with 41 additions and 7 deletions

View File

@ -1,13 +1,12 @@
COMMENT = backup and restoration manager for PostgreSQL
MODPY_EGG_VERSION = 2.19
MODPY_EGG_VERSION = 3.9.0
GH_ACCOUNT = EnterpriseDB
GH_PROJECT = barman
GH_TAGNAME = release/${MODPY_EGG_VERSION}
DISTNAME = barman-${MODPY_EGG_VERSION}
WRKDIST = ${WRKDIR}/barman-release-${MODPY_EGG_VERSION}
REVISION = 3
CATEGORIES = databases
HOMEPAGE = https://www.pgbarman.org/
@ -29,8 +28,18 @@ RUN_DEPENDS = databases/py-psycopg2${MODPY_FLAVOR} \
TEST_DEPENDS = devel/py-test-timeout${MODPY_FLAVOR} \
devel/py-test-runner${MODPY_FLAVOR}
pre-test:
rm ${WRKSRC}/tests/test*cloud* # some deps are not ported
# some cloud-related deps are not ported (esp for google/azure); pytest's
# collection of tets errors out if some of these are not ignored, and avoid
# noise from others
MODPY_PYTEST_ARGS= --ignore tests/test_barman_cloud_backup.py \
--ignore tests/test_barman_cloud_backup_show.py \
--ignore tests/test_barman_cloud_restore.py \
--ignore tests/test_barman_cloud_wal_archive.py \
--ignore tests/test_cloud.py \
--ignore tests/test_cloud_snapshot_interface.py \
--ignore tests/test_executor.py \
--ignore tests/test_infofile.py \
--ignore tests/test_output.py
post-install:
${INSTALL_DATA_DIR} ${PREFIX}/share/examples/barman

View File

@ -1,2 +1,2 @@
SHA256 (barman-2.19.tar.gz) = 0VMTWhoVgaWehRpMG8qVoZNO7OzaUgK8zd+jM5JqHiU=
SIZE (barman-2.19.tar.gz) = 1423229
SHA256 (barman-3.9.0.tar.gz) = C27nuJ4i1NQ2FVfHvo8mgos9MfkGdvxONbNerZiSFeo=
SIZE (barman-3.9.0.tar.gz) = 1819096

View File

@ -0,0 +1,20 @@
Index: barman/fs.py
--- barman/fs.py.orig
+++ barman/fs.py
@@ -19,6 +19,7 @@
import logging
import re
import shutil
+import sys
from abc import ABCMeta, abstractmethod
from barman import output
@@ -147,7 +148,7 @@ class UnixLocalCommand(object):
if not self.exists(path):
raise FsOperationFailed("Following path does not exist: %s" % path)
args = ["-c", "%a", path]
- if self.is_osx():
+ if self.is_osx() or sys.platform.startswith("openbsd"):
print("is osx")
args = ["-f", "%Lp", path]
cmd_ret = self.cmd("stat", args=args)

View File

@ -10,7 +10,7 @@ Index: setup.py
[
"doc/barman.1",
"doc/barman-cloud-backup.1",
@@ -76,7 +76,7 @@ setup(
@@ -77,7 +77,7 @@ setup(
"doc/barman-wal-restore.1",
],
),

View File

@ -16,6 +16,7 @@ bin/barman-cloud-backup
bin/barman-cloud-backup-delete
bin/barman-cloud-backup-keep
bin/barman-cloud-backup-list
bin/barman-cloud-backup-show
bin/barman-cloud-check-wal-archive
bin/barman-cloud-restore
bin/barman-cloud-wal-archive
@ -109,6 +110,8 @@ lib/python${MODPY_VERSION}/site-packages/barman/clients/${MODPY_PYCACHE}cloud_ba
lib/python${MODPY_VERSION}/site-packages/barman/clients/${MODPY_PYCACHE}cloud_backup_keep.${MODPY_PYC_MAGIC_TAG}pyc
lib/python${MODPY_VERSION}/site-packages/barman/clients/${MODPY_PYCACHE}cloud_backup_list.${MODPY_PYC_MAGIC_TAG}${MODPY_PYOEXTENSION}
lib/python${MODPY_VERSION}/site-packages/barman/clients/${MODPY_PYCACHE}cloud_backup_list.${MODPY_PYC_MAGIC_TAG}pyc
lib/python${MODPY_VERSION}/site-packages/barman/clients/${MODPY_PYCACHE}cloud_backup_show.${MODPY_PYC_MAGIC_TAG}${MODPY_PYOEXTENSION}
lib/python${MODPY_VERSION}/site-packages/barman/clients/${MODPY_PYCACHE}cloud_backup_show.${MODPY_PYC_MAGIC_TAG}pyc
lib/python${MODPY_VERSION}/site-packages/barman/clients/${MODPY_PYCACHE}cloud_check_wal_archive.${MODPY_PYC_MAGIC_TAG}${MODPY_PYOEXTENSION}
lib/python${MODPY_VERSION}/site-packages/barman/clients/${MODPY_PYCACHE}cloud_check_wal_archive.${MODPY_PYC_MAGIC_TAG}pyc
lib/python${MODPY_VERSION}/site-packages/barman/clients/${MODPY_PYCACHE}cloud_cli.${MODPY_PYC_MAGIC_TAG}${MODPY_PYOEXTENSION}
@ -129,6 +132,7 @@ lib/python${MODPY_VERSION}/site-packages/barman/clients/cloud_backup.py
lib/python${MODPY_VERSION}/site-packages/barman/clients/cloud_backup_delete.py
lib/python${MODPY_VERSION}/site-packages/barman/clients/cloud_backup_keep.py
lib/python${MODPY_VERSION}/site-packages/barman/clients/cloud_backup_list.py
lib/python${MODPY_VERSION}/site-packages/barman/clients/cloud_backup_show.py
lib/python${MODPY_VERSION}/site-packages/barman/clients/cloud_check_wal_archive.py
lib/python${MODPY_VERSION}/site-packages/barman/clients/cloud_cli.py
lib/python${MODPY_VERSION}/site-packages/barman/clients/cloud_compression.py
@ -191,6 +195,7 @@ lib/python${MODPY_VERSION}/site-packages/barman/xlog.py
@man man/man1/barman-cloud-backup-delete.1
@man man/man1/barman-cloud-backup-keep.1
@man man/man1/barman-cloud-backup-list.1
@man man/man1/barman-cloud-backup-show.1
@man man/man1/barman-cloud-backup.1
@man man/man1/barman-cloud-check-wal-archive.1
@man man/man1/barman-cloud-restore.1