update xapian-* ports to 1.4.24

This commit is contained in:
sthen 2023-11-09 13:05:30 +00:00
parent 20aab5b077
commit a7aba76449
10 changed files with 24 additions and 44 deletions

View File

@ -2,7 +2,7 @@ COMMENT-main= perl bindings for Xapian
COMMENT-python= python bindings for Xapian
COMMENT-ruby= ruby bindings for Xapian
V= 1.4.23
V= 1.4.24
DISTNAME= xapian-bindings-${V}
PKGNAME-main= xapian-bindings-perl-${V}
@ -23,14 +23,14 @@ SITES= https://oligarchy.co.uk/xapian/${V}/
EXTRACT_SUFX= .tar.xz
# -std=gnu++11
COMPILER= base-clang ports-gcc
COMPILER= base-clang ports-gcc
# base libtool doesn't support -shrext
USE_LIBTOOL= gnu
USE_LIBTOOL= gnu
LIB_DEPENDS= databases/xapian-core
LIB_DEPENDS= databases/xapian-core
BUILD_DEPENDS= textproc/py-sphinx${MODPY_FLAVOR}>=4.0.2
BUILD_DEPENDS= textproc/py-sphinx${MODPY_FLAVOR}
MODULES= lang/python \
lang/ruby
@ -40,9 +40,9 @@ MULTI_PACKAGES= -main -python -ruby
MODRUBY_RUNDEP= No
MODPY_RUNDEP= No
RUN_DEPENDS-python= textproc/py-sphinx${MODPY_FLAVOR}>=4.0.2 \
RUN_DEPENDS-python= textproc/py-sphinx${MODPY_FLAVOR} \
${MODPY_RUN_DEPENDS}
RUN_DEPENDS-ruby = ${MODRUBY_RUN_DEPENDS}
RUN_DEPENDS-ruby= ${MODRUBY_RUN_DEPENDS}
SUBST_VARS+= MODRUBY_BINREV
CONFIGURE_STYLE= autoconf

View File

@ -1,2 +1,2 @@
SHA256 (xapian-bindings-1.4.23.tar.xz) = 4LyMwOzwVoVJxQtR/Vnkz/tTGNbyAq/NRGWFXvXzP30=
SIZE (xapian-bindings-1.4.23.tar.xz) = 1076480
SHA256 (xapian-bindings-1.4.24.tar.xz) = UT1XhIgnkZis4TrUl1ENKyIgTV15S2QUPQW3vpdOts8=
SIZE (xapian-bindings-1.4.24.tar.xz) = 1112744

View File

@ -1,7 +1,7 @@
Index: configure.ac
--- configure.ac.orig
+++ configure.ac
@@ -1247,14 +1247,6 @@ if test yes = "$GXX" ; then
@@ -1207,14 +1207,6 @@ if test yes = "$GXX" ; then
dnl with GCC 2.95 and we don't support anything older.
SWIG_CXXFLAGS="-fno-strict-aliasing"

View File

@ -1,12 +0,0 @@
Index: perl/Makefile.in
--- perl/Makefile.in.orig
+++ perl/Makefile.in
@@ -1481,7 +1481,7 @@ clean-local:
auto/Xapian/Xapian$(PERL_SO): Xapian.la
@$(MKDIR_P) auto/Xapian
- $(LIBTOOL) --config > libtoolconfig.tmp
+ $(LIBTOOL) --config | grep -v pic > libtoolconfig.tmp
. ./libtoolconfig.tmp; cp "$$objdir/Xapian$(PERL_SO)" auto/Xapian
rm -f libtoolconfig.tmp

View File

@ -1,12 +0,0 @@
Index: python3/Makefile.in
--- python3/Makefile.in.orig
+++ python3/Makefile.in
@@ -1290,7 +1290,7 @@ xapian/__pycache__/__init__.@PYTHON3_CACHE_OPT1_EXT@:
xapian/_xapian$(PYTHON3_EXT_SUFFIX): _xapian.la
$(MKDIR_P) xapian
- $(LIBTOOL) --config > libtoolconfig.tmp
+ $(LIBTOOL) --config | grep -v pic > libtoolconfig.tmp
. ./libtoolconfig.tmp; cp $$objdir/_xapian$(PYTHON3_EXT_SUFFIX) xapian
rm -f libtoolconfig.tmp

View File

@ -1,6 +1,6 @@
COMMENT= search engine library
V= 1.4.23
V= 1.4.24
PORTROACH= limitw:1,even
DISTNAME= xapian-core-${V}
# the other xapian ports should be kept in-sync:

View File

@ -1,2 +1,2 @@
SHA256 (xapian-core-1.4.23.tar.xz) = MNNRgXIITzENq4bSYrUScYp/mhNjWqoaGI5h3CayKIw=
SIZE (xapian-core-1.4.23.tar.xz) = 3024644
SHA256 (xapian-core-1.4.24.tar.xz) = 7aWubc9rBVOoZ2r2Sx/TBOmYzSD3eQMcyq96uaNzUxo=
SIZE (xapian-core-1.4.24.tar.xz) = 3194164

View File

@ -79,7 +79,7 @@ share/doc/xapian-core/apidoc/
share/doc/xapian-core/apidoc/html/
share/doc/xapian-core/apidoc/html/annotated.html
share/doc/xapian-core/apidoc/html/bc_s.png
share/doc/xapian-core/apidoc/html/bdwn.png
share/doc/xapian-core/apidoc/html/bc_sd.png
share/doc/xapian-core/apidoc/html/classXapian_1_1AssertionError-members.html
share/doc/xapian-core/apidoc/html/classXapian_1_1AssertionError.html
share/doc/xapian-core/apidoc/html/classXapian_1_1AssertionError__inherit__graph.png
@ -354,7 +354,6 @@ share/doc/xapian-core/apidoc/html/database_8h.html
share/doc/xapian-core/apidoc/html/dbfactory_8h.html
share/doc/xapian-core/apidoc/html/deprecated.html
share/doc/xapian-core/apidoc/html/dir_f63502d618711192f85ccb772536c6ae.html
share/doc/xapian-core/apidoc/html/doc.png
share/doc/xapian-core/apidoc/html/document_8h.html
share/doc/xapian-core/apidoc/html/doxygen.css
share/doc/xapian-core/apidoc/html/dynsections.js
@ -364,8 +363,6 @@ share/doc/xapian-core/apidoc/html/errorhandler_8h.html
share/doc/xapian-core/apidoc/html/eset_8h.html
share/doc/xapian-core/apidoc/html/expanddecider_8h.html
share/doc/xapian-core/apidoc/html/files.html
share/doc/xapian-core/apidoc/html/folderclosed.png
share/doc/xapian-core/apidoc/html/folderopen.png
share/doc/xapian-core/apidoc/html/functions.html
share/doc/xapian-core/apidoc/html/functions_b.html
share/doc/xapian-core/apidoc/html/functions_c.html
@ -472,8 +469,10 @@ share/doc/xapian-core/apidoc/html/namespacemembers_type.html
share/doc/xapian-core/apidoc/html/namespacemembers_vars.html
share/doc/xapian-core/apidoc/html/namespaces.html
share/doc/xapian-core/apidoc/html/nav_f.png
share/doc/xapian-core/apidoc/html/nav_fd.png
share/doc/xapian-core/apidoc/html/nav_g.png
share/doc/xapian-core/apidoc/html/nav_h.png
share/doc/xapian-core/apidoc/html/nav_hd.png
share/doc/xapian-core/apidoc/html/open.png
share/doc/xapian-core/apidoc/html/pages.html
share/doc/xapian-core/apidoc/html/positioniterator_8h.html
@ -483,15 +482,20 @@ share/doc/xapian-core/apidoc/html/query_8h.html
share/doc/xapian-core/apidoc/html/queryparser_8h.html
share/doc/xapian-core/apidoc/html/registry_8h.html
share/doc/xapian-core/apidoc/html/splitbar.png
share/doc/xapian-core/apidoc/html/splitbard.png
share/doc/xapian-core/apidoc/html/stem_8h.html
share/doc/xapian-core/apidoc/html/structXapian_1_1LatLongCoord-members.html
share/doc/xapian-core/apidoc/html/structXapian_1_1LatLongCoord.html
share/doc/xapian-core/apidoc/html/sync_off.png
share/doc/xapian-core/apidoc/html/sync_on.png
share/doc/xapian-core/apidoc/html/tab_a.png
share/doc/xapian-core/apidoc/html/tab_ad.png
share/doc/xapian-core/apidoc/html/tab_b.png
share/doc/xapian-core/apidoc/html/tab_bd.png
share/doc/xapian-core/apidoc/html/tab_h.png
share/doc/xapian-core/apidoc/html/tab_hd.png
share/doc/xapian-core/apidoc/html/tab_s.png
share/doc/xapian-core/apidoc/html/tab_sd.png
share/doc/xapian-core/apidoc/html/tabs.css
share/doc/xapian-core/apidoc/html/termgenerator_8h.html
share/doc/xapian-core/apidoc/html/termiterator_8h.html

View File

@ -1,6 +1,6 @@
COMMENT= web search application
V= 1.4.23
V= 1.4.24
PORTROACH= limitw:1,even
DISTNAME= xapian-omega-${V}

View File

@ -1,2 +1,2 @@
SHA256 (xapian-omega-1.4.23.tar.xz) = e6Rg66cABNH0QpneTmLcyEAJkn5tUmBK5no+MBZeIg8=
SIZE (xapian-omega-1.4.23.tar.xz) = 571596
SHA256 (xapian-omega-1.4.24.tar.xz) = 0IdW5PM7GJFsyKJJPTEfHL647UNXvUD6XBdErcCA6/8=
SIZE (xapian-omega-1.4.24.tar.xz) = 580736