move fna3d to games/fna/fna3d, ok op@

This commit is contained in:
thfr 2024-01-24 19:47:31 +00:00
parent d082acbc39
commit c801e8e0bf
5 changed files with 58 additions and 0 deletions

34
games/fna/fna3d/Makefile Normal file
View File

@ -0,0 +1,34 @@
COMMENT = 3D graphics library for FNA
PKGNAME = fna3d-${V}
SHARED_LIBS = FNA3D 4.2 # 24.01
CATEGORIES += graphics
# zlib
PERMIT_PACKAGE = Yes
WANTLIB += SDL2
# base-gcc does not have thread-local storage
COMPILER = base-clang ports-gcc
COMPILER_LANGS = c
MODULES = devel/cmake
LIB_DEPENDS = devel/sdl2
USE_GMAKE = Yes
NO_TEST = Yes
WRKDIST = ${WRKDIR}/FNA/lib/FNA3D
SUBST_VARS += LIBFNA3D_VERSION
do-gen:
${SUBST_CMD} ${WRKSRC}/CMakeLists.txt
do-install:
${INSTALL_DATA} ${WRKSRC}/include/*.h ${PREFIX}/include/
${INSTALL_DATA} ${WRKBUILD}/libFNA3D.so.${LIBFNA3D_VERSION} ${PREFIX}/lib/
.include <bsd.port.mk>

2
games/fna/fna3d/distinfo Normal file
View File

@ -0,0 +1,2 @@
SHA256 (fna-2401.zip) = IGMiYXeEMEew3wWF+77gTWieqru/tv9MDBBvc0MkdCg=
SIZE (fna-2401.zip) = 3921429

View File

@ -0,0 +1,12 @@
Index: CMakeLists.txt
--- CMakeLists.txt.orig
+++ CMakeLists.txt
@@ -137,6 +137,8 @@ target_include_directories(FNA3D PUBLIC
$<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/src>
$<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/include>
$<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/Vulkan-Headers/include>
+ ${LOCALBASE}/include
+ ${X11BASE}/include
)
if(BUILD_DXVK_NATIVE)
add_definitions(-DFNA3D_DXVK_NATIVE)

View File

@ -0,0 +1,4 @@
FNA3D was written to be used for FNA's Graphics namespace. It carries the same
API design as XNA 4.0, with various implementations available at runtime
(including Vulkan, OpenGL, Metal, and Direct3D). For shaders, we support
Direct3D 9 Effect Framework binaries via MojoShader.

View File

@ -0,0 +1,6 @@
@pkgpath graphics/mojoshader
@pkgpath graphics/fna3d
include/FNA3D.h
include/FNA3D_Image.h
include/FNA3D_SysRenderer.h
@lib lib/libFNA3D.so.${LIBFNA3D_VERSION}