update to nut-2.8.1

This commit is contained in:
sthen 2023-11-02 13:11:50 +00:00
parent b99020bb25
commit e208564f22
10 changed files with 90 additions and 41 deletions

View File

@ -3,7 +3,7 @@ COMMENT-cgi= CGIs for monitoring Nut-based UPSs
COMMENT-snmp= driver for monitoring UPS via SNMP
COMMENT-xml= driver for monitoring UPS via XML/HTTP
V= 2.8.0
V= 2.8.1
DISTNAME= nut-${V}
PKGNAME-main= ${PKGNAME}
@ -11,15 +11,10 @@ PKGNAME-cgi= ${PKGNAME:S/-/-cgi-/}
PKGNAME-snmp= ${PKGNAME:S/-/-snmp-/}
PKGNAME-xml= ${PKGNAME:S/-/-xml-/}
REVISION-main= 1
REVISION-snmp= 0
REVISION-xml= 0
REVISION-cgi= 1
SHARED_LIBS += upsclient 4.0 # .4.0
SHARED_LIBS += nutclient 0.0 # .0.0
SHARED_LIBS += nutclientstub 0.0 # .1.0
SHARED_LIBS += nutscan 2.0 # .1.0
SHARED_LIBS += upsclient 4.0 # .6.1
SHARED_LIBS += nutclient 1.0 # .2.2
SHARED_LIBS += nutclientstub 1.0 # .1.1
SHARED_LIBS += nutscan 2.1 # .2.2
CATEGORIES= sysutils
HOMEPAGE= https://networkupstools.org/
@ -31,8 +26,9 @@ COMPILER= base-clang ports-gcc base-gcc
COMMON += c crypto pthread
WANTLIB-main += ${COMMON} ltdl m ssl ${COMPILER_LIBCXX} usb-1.0
WANTLIB-xml += ${COMMON} expat iconv intl neon proxy ssl z
WANTLIB-snmp += ${COMMON} m netsnmp
WANTLIB-xml += ${COMMON} expat iconv intl neon proxy ssl z \
nghttp2 nghttp3 ngtcp2 ngtcp2_crypto_quictls
WANTLIB-snmp += ${COMMON} m netsnmp ssl
WANTLIB-cgi += ${COMMON} X11 expat fontconfig iconv intl
WANTLIB-cgi += freetype gd jpeg m png ssl upsclient xcb z
@ -135,9 +131,8 @@ post-install:
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/nut/
cd ${WRKSRC}/docs; cp -R ../[A-LN-Z]* ../MAINTAINERS \
cables images ${PREFIX}/share/doc/nut/
-cd ${WRKSRC}/docs; cp -R *html ${PREFIX}/share/doc/nut/
-cd ${WRKSRC}/docs; cp -R *txt ${PREFIX}/share/doc/nut/
${INSTALL_SCRIPT} ${WRKSRC}/scripts/avahi/nut.service \
${PREFIX}/share/examples/nut
rm -r ${PREFIX}/share/nut/solaris-init
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
SHA256 (nut-2.8.0.tar.gz) = w+WnCNp5e3xwtlPTexIGoAD8tQO4VRn+TN9jU/eSv+U=
SIZE (nut-2.8.0.tar.gz) = 3287640
SHA256 (nut-2.8.1.tar.gz) = faSO4jsfDY1yVguwr4T1xa5NvjVFK4TLSYQBMuR/CZw=
SIZE (nut-2.8.1.tar.gz) = 4125263

View File

@ -1,7 +1,7 @@
Index: clients/Makefile.am
--- clients/Makefile.am.orig
+++ clients/Makefile.am
@@ -55,10 +55,13 @@ upssched_LDADD = $(top_builddir)/common/libcommon.la $
@@ -79,10 +79,13 @@ upssched_LDADD = $(top_builddir)/common/libcommonclien
upsimage_cgi_SOURCES = upsimage.c upsclient.h upsimagearg.h cgilib.c cgilib.h
upsimage_cgi_LDADD = $(LDADD) $(LIBGD_LDFLAGS)
@ -13,5 +13,5 @@ Index: clients/Makefile.am
upsimagearg.h cgilib.c cgilib.h
+upsstats_cgi_LDFLAGS = $(LDFLAGS) -all-static
# not LDADD.
# not LDADD... why?
libupsclient_la_SOURCES = upsclient.c upsclient.h

View File

@ -1,7 +1,7 @@
Index: clients/cgilib.c
--- clients/cgilib.c.orig
+++ clients/cgilib.c
@@ -165,7 +165,7 @@ int checkhost(const char *host, char **desc)
@@ -166,7 +166,7 @@ int checkhost(const char *host, char **desc)
if (!host)
return 0; /* deny null hostnames */

View File

@ -1,7 +1,7 @@
Index: clients/upsset.c
--- clients/upsset.c.orig
+++ clients/upsset.c
@@ -193,7 +193,7 @@ static void do_pickups(const char *currfunc)
@@ -197,7 +197,7 @@ static void do_pickups(const char *currfunc)
char hostfn[SMALLBUF];
PCONF_CTX_t ctx;
@ -10,7 +10,7 @@ Index: clients/upsset.c
printf("<FORM METHOD=\"POST\" ACTION=\"upsset.cgi\">\n");
@@ -1018,7 +1018,7 @@ static void check_conf(void)
@@ -1023,7 +1023,7 @@ static void check_conf(void)
char fn[SMALLBUF];
PCONF_CTX_t ctx;

View File

@ -1,8 +1,8 @@
Index: common/common.c
--- common/common.c.orig
+++ common/common.c
@@ -535,6 +535,17 @@ const char * confpath(void)
return path;
@@ -1429,6 +1429,17 @@ const char * confpath(void)
return (path != NULL && *path != '\0') ? path : CONFPATH;
}
+/* return a config path for the CGIs so they can be kept seperate */

View File

@ -1,16 +1,15 @@
Index: conf/ups.conf.sample
--- conf/ups.conf.sample.orig
+++ conf/ups.conf.sample
@@ -127,7 +127,7 @@ maxretry = 3
# apcsmart, bestups, and sec are some examples.
#
@@ -139,6 +139,7 @@ maxretry = 3
# port: REQUIRED. The serial port where your UPS is connected.
-# /dev/ttyS0 is usually the first port on Linux boxes, for example.
+# /dev/tty00 is usually the first port on OpenBSD boxes, for example.
#
# sdorder: OPTIONAL. When you have multiple UPSes on your system, you
# usually need to turn them off in a certain order. upsdrvctl
@@ -181,11 +181,11 @@ maxretry = 3
# For example:
# /dev/ttyS0 is usually the first port on Linux boxes.
+# /dev/tty00 is usually the first port on OpenBSD boxes.
# "\\\\.\\COM1" is the first port on Windows boxes (note that
# the backslash characters themselves must be escaped,
# for the NUT configuration parser to yield "\\.\COM1").
@@ -195,11 +196,11 @@ maxretry = 3
# --------
#
# A simple example for a UPS called "powerpal" that uses the blazer_ser
@ -24,7 +23,7 @@ Index: conf/ups.conf.sample
# desc = "Web server"
#
# If your UPS driver requires additional settings, you can specify them
@@ -200,3 +200,17 @@ maxretry = 3
@@ -214,3 +215,17 @@ maxretry = 3
#
# To find out if your driver supports any extra settings, start it with
# the -h option and/or read the driver's documentation.

View File

@ -1,12 +1,12 @@
Index: conf/upsmon.conf.sample.in
--- conf/upsmon.conf.sample.in.orig
+++ conf/upsmon.conf.sample.in
@@ -149,7 +149,7 @@ MINSUPPLIES 1
# such as posting a message with 'logger' or 'wall' or 'mailx'. Do be careful
# to plug the UPS back into the wall in a timely fashion.
@@ -157,7 +157,7 @@ MINSUPPLIES 1
# Or use the old DOS 8.3 file name, like this:
# SHUTDOWNCMD "C:\\PROGRA~1\\SOMECO~1.bat -first_arg -second_arg"
-SHUTDOWNCMD "/sbin/shutdown -h +0"
+SHUTDOWNCMD "/sbin/shutdown -hp +0"
# --------------------------------------------------------------------------
# NOTIFYCMD <command>
# SHUTDOWNEXIT <boolean|num>

View File

@ -1,7 +1,7 @@
Index: include/common.h
--- include/common.h.orig
+++ include/common.h
@@ -138,6 +138,9 @@ void syslogbit_set(void);
@@ -255,6 +255,9 @@ void syslogbit_set(void);
/* Return the default path for the directory containing configuration files */
const char * confpath(void);

View File

@ -56,6 +56,7 @@
@bin bin/riello_usb
@bin bin/safenet
@bin bin/skel
@bin bin/sms_ser
@bin bin/solis
@bin bin/tripplite
@bin bin/tripplite_usb
@ -99,6 +100,15 @@ lib/pkgconfig/libnutclient.pc
lib/pkgconfig/libnutclientstub.pc
lib/pkgconfig/libnutscan.pc
lib/pkgconfig/libupsclient.pc
@comment lib/python2.7/
@comment lib/python2.7/site-packages/
@comment lib/python2.7/site-packages/PyNUT.py
@comment lib/python2.7/site-packages/test_nutclient.py
lib/python${MODPY_VERSION}/
lib/python${MODPY_VERSION}/site-packages/
lib/python${MODPY_VERSION}/site-packages/PyNUT.py
lib/python${MODPY_VERSION}/site-packages/test_nutclient.py
@bin libexec/sockdebug
@man man/man3/libnutclient.3
@man man/man3/libnutclient_commands.3
@man man/man3/libnutclient_devices.3
@ -139,7 +149,10 @@ lib/pkgconfig/libupsclient.pc
@man man/man3/nutscan_add_option_to_device.3
@man man/man3/nutscan_cidr_to_ip.3
@man man/man3/nutscan_display_parsable.3
@man man/man3/nutscan_display_sanity_check.3
@man man/man3/nutscan_display_sanity_check_serial.3
@man man/man3/nutscan_display_ups_conf.3
@man man/man3/nutscan_display_ups_conf_with_sanity_check.3
@man man/man3/nutscan_free_device.3
@man man/man3/nutscan_get_serial_ports_list.3
@man man/man3/nutscan_init.3
@ -225,6 +238,8 @@ lib/pkgconfig/libupsclient.pc
@man man/man8/riello_ser.8
@man man/man8/riello_usb.8
@man man/man8/safenet.8
@man man/man8/sms_ser.8
@man man/man8/sockdebug.8
@man man/man8/solis.8
@man man/man8/tripplite.8
@man man/man8/tripplite_usb.8
@ -252,16 +267,24 @@ share/doc/nut/
share/doc/nut/AUTHORS
share/doc/nut/COPYING
share/doc/nut/ChangeLog
share/doc/nut/ChangeLog.txt
share/doc/nut/FAQ.txt
share/doc/nut/INSTALL
share/doc/nut/INSTALL.nut
share/doc/nut/INSTALL.nut.adoc
share/doc/nut/LICENSE-DCO
share/doc/nut/LICENSE-GPL2
share/doc/nut/LICENSE-GPL3
share/doc/nut/MAINTAINERS
share/doc/nut/NEWS
share/doc/nut/NEWS.adoc
share/doc/nut/README
share/doc/nut/TODO
share/doc/nut/UPGRADING
share/doc/nut/README.adoc
share/doc/nut/TODO.adoc
share/doc/nut/UPGRADING.adoc
share/doc/nut/acknowledgements.txt
share/doc/nut/asciidoc.txt
share/doc/nut/cables/
share/doc/nut/cables.txt
share/doc/nut/cables/Makefile
share/doc/nut/cables/Makefile.am
share/doc/nut/cables/Makefile.in
@ -273,6 +296,20 @@ share/doc/nut/cables/mgeups.txt
share/doc/nut/cables/powerware.txt
share/doc/nut/cables/repotec.txt
share/doc/nut/cables/sms.txt
share/doc/nut/ci-farm-lxc-setup.txt
share/doc/nut/config-notes.txt
share/doc/nut/config-prereqs.txt
share/doc/nut/configure.txt
share/doc/nut/contact-closure.txt
share/doc/nut/daisychain.txt
share/doc/nut/design.txt
share/doc/nut/developer-guide.txt
share/doc/nut/developers.txt
share/doc/nut/documentation.txt
share/doc/nut/download.txt
share/doc/nut/features.txt
share/doc/nut/hid-subdrivers.txt
share/doc/nut/history.txt
share/doc/nut/images/
share/doc/nut/images/advanced.png
share/doc/nut/images/asciidoc.png
@ -297,6 +334,24 @@ share/doc/nut/images/nut_layering.png
share/doc/nut/images/old-cgi.png
share/doc/nut/images/simple.png
share/doc/nut/images/warning.png
share/doc/nut/macros.txt
share/doc/nut/net-protocol.txt
share/doc/nut/new-clients.txt
share/doc/nut/new-drivers.txt
share/doc/nut/nut-names.txt
share/doc/nut/nut-qa.txt
share/doc/nut/nutdrv_qx-subdrivers.txt
share/doc/nut/outlets.txt
share/doc/nut/packager-guide.txt
share/doc/nut/release-notes.txt
share/doc/nut/scheduling.txt
share/doc/nut/security.txt
share/doc/nut/snmp-subdrivers.txt
share/doc/nut/snmp.txt
share/doc/nut/sock-protocol.txt
share/doc/nut/solaris-usb.txt
share/doc/nut/support.txt
share/doc/nut/user-manual.txt
share/doc/pkg-readmes/${PKGSTEM}
share/examples/nut/
@sample ${SYSCONFDIR}/