just remove hwsensorsbeat. unmaintained upstream and in fact i forgot i even wrote this

ok espie@
This commit is contained in:
jasper 2023-11-12 14:46:01 +00:00
parent b1d7dfeab9
commit fc2ee519f7
9 changed files with 3 additions and 58 deletions

View File

@ -3,7 +3,7 @@ CATEGORIES = devel databases
DISTFILES =
# API.rev
PKGNAME = quirks-6.187
PKGNAME = quirks-6.188
PKG_ARCH = *
MAINTAINER = Marc Espie <espie@openbsd.org>

View File

@ -1,7 +1,7 @@
#! /usr/bin/perl
# ex:ts=8 sw=4:
# $OpenBSD: Quirks.pm,v 1.1583 2023/11/11 14:53:33 sthen Exp $
# $OpenBSD: Quirks.pm,v 1.1584 2023/11/12 14:46:01 jasper Exp $
#
# Copyright (c) 2009 Marc Espie <espie@openbsd.org>
#
@ -1889,6 +1889,7 @@ setup_obsolete_reason(
3 => 'driconf',
3 => 'GAMMApage',
3 => 'comix',
3 => 'hwsensorsbeat',
);
# though it's not yet used, these should be pkgnames, so that eventually

View File

@ -1,7 +1,6 @@
SUBDIR =
SUBDIR += filebeat
SUBDIR += heartbeat
#SUBDIR += hwsensorsbeat
SUBDIR += metricbeat
SUBDIR += packetbeat

View File

@ -1,20 +0,0 @@
COMMENT = lightweight shipper for hw.sensors data
UNLINKED = hwsensorsbeat
BEAT = hwsensorsbeat
VERSION = 0.1.2
REVISION = 4
GH_ACCOUNT = jasperla
GH_PROJECT = ${BEAT}
GH_TAGNAME = ${VERSION}
MAINTAINER = Jasper Lievisse Adriaanse <jasper@openbsd.org>
ELASTIC_BEAT = No
WANTLIB = c pthread
CONFIGS = hwsensorsbeat.yml hwsensorsbeat.template.json
.include <bsd.port.mk>

View File

@ -1,2 +0,0 @@
SHA256 (hwsensorsbeat-0.1.2.tar.gz) = xj1PpKxzIeCgJDPppkQ2kMJI2pdmV42SumFtKuWNCGk=
SIZE (hwsensorsbeat-0.1.2.tar.gz) = 12286762

View File

@ -1,12 +0,0 @@
/usr/include/sys/sensors.h:110: error: field 'tv' has incomplete type
--- beater/hwsensorsbeat.go.orig Sat Sep 10 12:22:39 2016
+++ beater/hwsensorsbeat.go Sat Sep 10 12:22:47 2016
@@ -2,6 +2,7 @@ package beater
/*
#include <sys/types.h>
+#include <sys/select.h>
#include <sys/sysctl.h>
#include <sys/sensors.h>
*/

View File

@ -1,2 +0,0 @@
Lightweight shipper for OpenBSD sensors information, reading the data
from hw.sensors.

View File

@ -1,8 +0,0 @@
@bin bin/hwsensorsbeat
share/examples/hwsensorsbeat/
@sample ${SYSCONFDIR}/hwsensorsbeat/
share/examples/hwsensorsbeat/hwsensorsbeat.template.json
@sample ${SYSCONFDIR}/hwsensorsbeat/hwsensorsbeat.template.json
share/examples/hwsensorsbeat/hwsensorsbeat.yml
@sample ${SYSCONFDIR}/hwsensorsbeat/hwsensorsbeat.yml
@rcscript ${RCDIR}/hwsensorsbeat

View File

@ -1,11 +0,0 @@
#!/bin/ksh
daemon="${PREFIX}/bin/hwsensorsbeat"
daemon_flags="-c ${SYSCONFDIR}/hwsensorsbeat/hwsensorsbeat.yml"
. /etc/rc.d/rc.subr
rc_bg=YES
rc_reload=NO
rc_cmd $1