Move amd64 and arm64 to use devel/gas; riscv64 still needs devel/binutils

While here, add a patch to have arm64 build, upstreamed by tobhe@
ok tobhe@
This commit is contained in:
bcallah 2023-12-12 22:24:20 +00:00
parent f6fcb284da
commit fd2cb7ba2c
3 changed files with 22 additions and 4 deletions

View File

@ -17,7 +17,7 @@ do-gen:
cp ${WRKSRC}/configs/openbsd.mk ${WRKSRC}/config.mk
sed -i "s/aarch64-//g" ${WRKSRC}/config.mk
sed -i "s/riscv64-//g" ${WRKSRC}/config.mk
.if ${MACHINE_ARCH:Marm64}
.if ${MACHINE_ARCH:Maarch64} || ${MACHINE_ARCH:Mriscv64}
echo "ARCH = $$(arch -s)" >> ${WRKSRC}/config.mk
.endif

View File

@ -1,4 +1,5 @@
DISTNAME = harec-0.0.0pl20231202
REVISION = 0
WANTLIB += c m
@ -7,9 +8,15 @@ COMPILER = base-clang ports-gcc
BUILD_DEPENDS = ${RUN_DEPENDS}
# Needs a newer GNU as
RUN_DEPENDS = devel/binutils \
lang/qbe
RUN_DEPENDS = lang/qbe
# All archs need a newer GNU as
# gas-2.31.1 is not new enough for riscv64
.if ${MACHINE_ARCH:Mriscv64}
RUN_DEPENDS += devel/binutils
.else
RUN_DEPENDS += devel/gas
.endif
CONFIGURE_STYLE = simple
CONFIGURE_ARGS = --sysconfdir="${SYSCONFDIR}"

View File

@ -0,0 +1,11 @@
Already upstreamed, from tobhe@
Index: rt/+openbsd/start+aarch64.s
--- rt/+openbsd/start+aarch64.s.orig
+++ rt/+openbsd/start+aarch64.s
@@ -5,5 +5,4 @@ _start:
mov x30, #0
mov x0, sp
add sp, x0, #-16
- and sp, sp, #-16
b rt.start_ha